Craftcom
Neděle, 28.02.2021, 03:56 *
Vítej, Host. Prosím přihlaš se nebo se zaregistruj.
Nedostal jsi svůj aktivační email?

Přihlaš se uživatelským jménem, heslem a délkou sezení
Novinky: Dne 24.2.2008 byl po delší odstávce uveden do provozu nový portál s fórem. Chtěli bychom vás požádat v případě nalezení nějaké chyby nebo nefunkčního odkazu o napsání zprávy do vlákna "Chyby" pro pružnější sjednání nápravy.
 
   Domů   Nápověda Vyhledávání Přihlásit Registrovat  
Stran: [1]   Dolů
  Tisk  
Autor Téma: Chyby češtiny v XPE  (Přečteno 3406 krát)
0 uživatelů a 1 Host prohlíží toto téma.
FJelinek
Nováček
*
Offline Offline

Příspěvků: 3


Zobrazit profil
« kdy: Pátek, 24.10.2008, 16:10 »

Dobrý den,
v mnou sestavených xpe (command shell) mám problém s češtinou respektive s nastavením znakové sady (špatně se zobrazují znaky ř,š...)
Do sestavení mám zahrnutu komponentu czech language support (fonts: Central Europe bitmap fonts, Code pages conversion tables : 1250 (ANSI - Central Europe) 28592 (ISO 8859-2 Central Europe) 852 (OEM - Latin II), Keyboard layouts : nemám zvolený žádný)
V komponentě Regional and Language Options mám vše nastaveno na Czech a přesto je zobrazení znaků nekorektní.
Nemáte s tím někdo zkušenosti?

Dále mě také trochu zarazilo, že v logu instalace Service Pack 1 Czech MUI Pack jsem našel, že se nainstalovali komponenty typu  Microsoft Taiwan CJIME98b Core a podobné viz. výpis logu.

The following objects were imported into the database on FJELINEK:
Components:
    Czech MUI Resource
    Czech Help Engine UI
    Czech App Help MUI
    Czech ER MUI
    Czech Internet Explorer MUI
    Czech Movie Maker MUI
    Czech PCHealth Help MUI
    Czech Shell MUI
    Czech Windows Media MUI
    Czech WM PRX MUI
    Czech Search Assistant MUI
    Czech Windows Tour MUI
    Fonts: cga40850_fon
    Fonts: Chinese (Simplified) bitmap & TrueType fonts
    Fonts: Chinese (Traditional) bitmap & TrueType fonts
    Fonts: Fonts georgia_bold_italic
    Fonts: Korean bitmap & TrueType fonts
    Fonts: Korean font substitutes
    IME Prototype
    Language: Chinese (China) - 0804
    Language: Chinese (Taiwan) - 0404
    Regional and Language Options
    Arabic Language Support
    Chinese - Simplified Language Support
    Chinese - Traditional Language Support
    Czech Language Support
    Greek Language Support
    Hebrew Language Support
    Hungarian Language Support
    Korean Language Support
    Polish Language Support
    Russian Language Support
    Thai Language Support
    Turkish Language Support
    Japanese CMD MUI
    East Asia Console IME
    Korean CMD MUI
    Chinese - Traditional CMD MUI
    Chinese - Simplified CMD MUI
    CMD MUI Prototype
    Microsoft Taiwan CJIME98b Core
    Microsoft Taiwan IME Program
    Microsoft Korean IME Core
    Microsoft Taiwan PHIME2002a Core
    Microsoft Simplified Chinese IME Core
    User Locale: Chinese - China
    User Locale: Chinese - Taiwan

Repositories:
    Czech MUI resource repository
    Console Repository

Other Groups:
    Czech custom MUI components
    Czech Language UI Support Package
    Language Component Update Pack 1
    Language Component Update Pack 2
    Arabic Language Extended Support
    Arabic Locales Group
    Chinese - Simplified Language Extended Support
    Chinese - Simplified Locales Group
    Chinese - Traditional Language Extended Support
    Chinese - Traditional Locales Group
    Czech Language Extended Support
    Czech Locales Group
    Greek Language Extended Support
    Greek Locales Group
    Hebrew Language Extended Support
    Hebrew Locales Group
    Hungarian Language Extended Support
    Hungarian Locales Group
    Korean Language Extended Support
    Korean Locales Group
    Polish Language Extended Support
    Polish Locales Group
    Russian Language Extended Support
    Russian Locales Group
    Thai Language Extended Support
    Thai Locales Group
    Turkish Language Extended Support
    Turkish Locales Group


WEUpdate Exiting with return code: 0

   **** End Of Run ****

Je toto normální?
Zaznamenáno
FJelinek
Nováček
*
Offline Offline

Příspěvků: 3


Zobrazit profil
« Odpověď #1 kdy: Čtvrtek, 06.11.2008, 10:35 »

Problém vyřešen pomocí zápisu do registru.

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FontAssoc\Associated Charset]
"ANSI(00)"="YES"
"OEM(FF)"="YES"
"SYMBOL(02)"="NO"

Pro upřesnění chyby. V XPE byla čeština celou dobu v pořádku, ale program který šel na XP Profesional bez chyby měl na XPE problémy s diakritikou.
Zaznamenáno
Stran: [1]   Nahoru
  Tisk  
 
Skočit na:  

Poháněno MySQL Poháněno PHP Powered by SMF 1.1.20 | SMF © 2006, Simple Machines Validní XHTML 1.0! Validní CSS!